Categories: Uncategorized

Start or Stop Workstation service from command line (CMD)

Workstation service enables access to network shares. If this service is not running we can’t access any SMB shares from the machine. We can start the service from services management console(Services.msc). We can start workstation service from command prompt also using the below command. On Vista and Windows 7 you need to run this command from elevated administrator command prompt. Otherwise you will get access denied error like the one below.

C:>net start workstation
System error 5 has occurred.
Access is denied.

In case if you get error as in the example below you need to first enable the service on the machine.

C:Documents and Settingsadministrator>net start workstation
System error 1058 has occurred.
The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.

To Enable workstation service:

sc config lanmanworkstation start= demand

In the above command you can use any of the options {boot, system, auto or demand} to enable the service.

To disable the service you need to run the following command.

sc config lanmanworkstation start= disabled

To stop workstation service:

net stop workstation
Srini

View Comments

  • I am getting the error "service name is invalid"
    when I run the above command. What could be the issue?

  • workstation and lanmanworkstation are not configured and are not installed services, what windows option needs to be installed?

  • Kyler,
    You can install workstation service in the following way.

    Run ncpa.cpl from Run window.
    Right click on the network connection you are using
    Select properties
    Under General tab click on install button
    Select client and click on add
    Select client for microsoft networks
    Select OK and close the windows..

  • C:\Windows\system32>net start workstation
    System error 1079 has occurred.

    The account specified for this service is different from the account specified f
    or other services running in the same process.

    -- How can solve this error.Please help me ?

    • C:\Windows\system32>net start workstation
      System error 1079 has occurred.

      The account specified for this service is different from the account specified f
      or other services running in the same process.

      — How can solve this error.Please help me ?

  • "windows could not start the workstation service on local computer. Error 1068 : The dependency service or group failed to start"

    what we can do fix this ?

    OS Name    Microsoft Windows Server 2008 R2 Enterprise
    Version    6.1.7601 Service Pack 1 Build 7601
    OS Manufacturer    Microsoft Corporation
    System Manufacturer    VMware, Inc.
    System Model    VMware Virtual Platform
    System Type    x64-based PC

Recent Posts

Add new user account from command line (CMD)

Adding users from command line is much easier than going through the UI. It saves…

4 years ago

Delete directory from command line [Rmdir]

Do you want to delete a directory from Windows command prompt(CMD)? This post explains how…

4 years ago

TaskKill: Kill process from command line (CMD)

We can kill a process from GUI using Task manager. If you want to do…

4 years ago

Kill Chrome from command line

Chrome is definitely the stable browser compared to other ones and it has been my…

4 years ago

Find windows OS version from command line

Windows has multiple command line utilities that can help find the version of the Windows…

4 years ago

How to check if Windows 32 or 64 bit?

There are multiple ways to check whether a Windows computer is running 32-bit OS or…

7 years ago